Hydraulic woes!!!

Hydraulic woes!!!

Postby Chug » Fri Apr 27, 2018 12:59 pm

So here is my issue,
I'm swapping a Isuzu 5spd into my Indy, in place of the TH125. I got the trans, flywheel, clutch, pressure-plate, shifter, cables and throw-out bearing from a running car. I bought the "Early Clutch Master" and Isuzu 5spd Slave from Rodney. New lines from Fiero Store and a pedal assembly from Ebay. After putting it together I am having a problem getting the clutch to release enough to be able to put into gear. I have bled, bled and bled some more, there is no air in the system, checked the pedal that it does throw all the way before touching the floor. I have a Ram clutch kit on order from Fiero Store. I'm just wondering if I have missed something or done something wrong or put the wrong parts together? If anyone sees a problem with anything listed please let me know!!!
Yes it can be done, it just depends on how deep your wallet is!
User avatar
Chug
Moderator
 
Posts: 293
Joined: Mon Jun 11, 2012 2:02 pm

Re: Hydraulic woes!!!

Postby Trinten » Tue Oct 30, 2018 4:48 pm

Hey Chug,

As I know you got this fixed, do you want to share what the solution was?
1986 Pontiac Fiero GT, 355 cubic inch small block Chevy putting down 371 HP and 381 ft/lbs torque at the wheels, with more to come!
User avatar
Trinten
Site Admin
 
Posts: 512
Joined: Mon Jun 04, 2012 7:02 pm
Location: Charlotte, N.C.



Return to Troubleshooting




Users browsing this forum: No registered users and 1 guest

cron